[Quickbase Status] Notice: Quickbase University Down Time (Maintenance)

Maintenance
09/08/2026, 07:29pm EDT

[Quickbase Status] Notice: Quickbase University Down Time (Maintenance)

Status: closed
Start: 09/08/2026, 07:00pm EDT
End: 09/08/2026, 07:29pm EDT
Duration: 29 minutes
Affected Components:
Quickbase University
Update

09/08/2026, 07:00pm EDT

09/08/2026, 07:00pm EDT

The Quickbase team will be performing maintenance on the Quickbase University website Tuesday, September 8, between 7:00 PM and 7:30 PM Eastern US Time.

During this maintenance window there may be a a brief period of downtime where users are unable to load the university.quickbase.com website. You may continue to access Quickbase University content during this period by visiting https://app.brainstorminc.com/?alias=qbu.

Resolved

09/08/2026, 07:29pm EDT

09/08/2026, 07:29pm EDT

This incident is closed.